Knowledgebase

What software and program versions does Executive Web Hosting offer?

Quick Reference

Apache 2.2.17
PHP 5.2.15 and 5.3.4 (dual environment)
Perl 5.8.8
MySQL 5.1.52
cPanel 11.28, auto updated to latest version
GD / Image Magick 6.6.3

All accounts come with:

  • Linux x86 CentOS 5.5 (a free version of RedHat) 32 bit Operating System
  • Kernel 2.6.34.6
  • Dual Xeon E5520 2.26 GHz Quad Core Processors
  • Apache 2.2.x, (includes mod_rewrite and mod_security) in a SuExec environment
  • exim Internet Mailer
  • WHM 11.28.x
  • cPanel 11.28.x
  • PHP 5.2.x and 5.3.x, PHP is run as CGI (not Apache/DSO) in a suPHP environment
  • Zend Optimizer 3.3.9, PEAR 1.7.x, ionCube 3.3.7, GnuPG 1.2.6, GD2 Library (2.0.34), openSSL 0.9.8o, SOAP
  • PHP Modules - full list
  • phpMyAdmin 3.2.4
  • MySQL Database 5.1.x
  • cURL 7.15.x (also libcurl and PHP/CURL)
  • PERL 5.8.x, PCRE Library Version 7.8
  • Python 2.7
  • ImageMagick 6.6.x
  • Ghostscript 8.15.x
  • Rsync
  • RoundCube 0.2b, SquirrelMail 1.4.13, Horde 3.1.7p8
  • Fantastico Scripts [see versions]: Blogs (WordPress), CMS (Drupal and Joomla), Discussion Boards (phpBB3), Shopping Carts (osCommerce), Image Galleries, php Mailing List, Sitebuilders, Wiki

We do our best to keep software and program versions as up to date as possible. Our technical team regularly evaluates software updates and pushes updates to Executive Web Hosting's server as they are deemed secure and appropriate for Executive Web Hosting's shared hosting environment.



Was this answer helpful?

Add to Favourites Add to Favourites

Print this Article Print this Article

Also Read
PHP 5.3 (Views: 1173)
About Apache (Views: 722)
Do you support LAMP? (Views: 630)

Powered by WHMCompleteSolution